View Issue Details

IDProjectCategoryView StatusLast Update
0000916OpenMPT[All Projects] Generalpublic2017-02-12 17:55
Reporterpigdevil2010 
Assigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.27.00.* (current testing) 
Target VersionOpenMPT 1.27.01.00 (upcoming stable)Fixed in VersionOpenMPT 1.27.01.00 (upcoming stable) 
Summary0000916: Plugin arpeggio not always stopped properly
Description

The exported .mid sometimes lack note off and forgot to stop running some effects such as arpeggio especially when there's an instrument change in the same channel. This resulted in a very big file with thousands of hold notes on the end. Also, midi export currently treats tone portamento as continue NNA.

This problem also occurs in MIDI in/out plugin and doesn't occur in old versions where there's no effect support.

TagsNo tags attached.
Has the bug occurred in previous versions?

Yes, since like 1.25

Tested code revision (in case you know it)

Relationships

Activities

Saga Musix

Saga Musix

2017-02-05 14:37

administrator   ~0002863

Last edited: 2017-02-05 14:42

View 2 revisions

Also, midi export currently treats tone portamento as continue NNA.

This is documented: MIDI Export behaves the same as if every instrument was a VSTi. This cannot be fixed easily.

Regarding the other problems, please provide a small example file to have a look at.

Saga Musix

Saga Musix

2017-02-12 17:15

administrator   ~0002877

Okay, I could reproduce the problem with plugin arpeggio sometimes hanging after an instrument change, this has been fixed in r7587. However, even before that, it should not result in a big file. If there are any other issues with MIDI export (apart from the known portamento treatment), please open a new new issue for them with a clear description of what's broken.

Saga Musix

Saga Musix

2017-02-12 17:55

administrator   ~0002878

There was an issue in r7587, so r7589 should really fix the issue now.

Issue History

Date Modified Username Field Change
2017-02-05 14:20 pigdevil2010 New Issue
2017-02-05 14:37 Saga Musix Note Added: 0002863
2017-02-05 14:42 Saga Musix Note Edited: 0002863 View Revisions
2017-02-12 17:15 Saga Musix Assigned To => Saga Musix
2017-02-12 17:15 Saga Musix Severity major => minor
2017-02-12 17:15 Saga Musix Status new => resolved
2017-02-12 17:15 Saga Musix Resolution open => fixed
2017-02-12 17:15 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-02-12 17:15 Saga Musix Target Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-02-12 17:15 Saga Musix Summary MIDI export is broken => Plugin arpeggio not always stopped properly
2017-02-12 17:15 Saga Musix Note Added: 0002877
2017-02-12 17:55 Saga Musix Note Added: 0002878