View Issue Details

IDProjectCategoryView StatusLast Update
0000888OpenMPT[All Projects] Generalpublic2016-11-20 17:50
Reporterpigdevil2010Assigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.06.00 / libopenmpt 0.2-beta20.2 (upgrade first) 
Target VersionOpenMPT 1.26.07.00 / libopenmpt 0.2-beta20.3 (upgrade first)Fixed in VersionOpenMPT 1.26.07.00 / libopenmpt 0.2-beta20.3 (upgrade first) 
Summary0000888: Tremolo issue
Description

Due to OpenMPT 1.26.06.00's .mod tremolo fix, it's now broken in every format when coupled with volume command. As shown in the attached file. Notable song that uses this is The Day They Landed (theday.xm) which is one of example modules in MilkyTracker.

TagsNo tags attached.
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)

Activities

pigdevil2010

pigdevil2010

2016-11-12 14:17

reporter  

brokentremolo.zip (440 bytes)
Saga Musix

Saga Musix

2016-11-12 15:50

administrator   ~0002733

Oops. This is not directly caused by the fix for MOD files, but rather some related code that was "fixed" at the same time. Fixed in r7357.

Issue History

Date Modified Username Field Change
2016-11-12 14:16 pigdevil2010 New Issue
2016-11-12 14:17 pigdevil2010 File Added: brokentremolo.zip
2016-11-12 15:42 Saga Musix Assigned To => Saga Musix
2016-11-12 15:42 Saga Musix Status new => assigned
2016-11-12 15:50 Saga Musix Status assigned => resolved
2016-11-12 15:50 Saga Musix Resolution open => fixed
2016-11-12 15:50 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-11-12 15:50 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-11-12 15:50 Saga Musix Note Added: 0002733
2016-11-20 17:50 Saga Musix Fixed in Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.07.00 / libopenmpt 0.2-beta20.3 (upgrade first)
2016-11-20 17:50 Saga Musix Target Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.07.00 / libopenmpt 0.2-beta20.3 (upgrade first)