View Issue Details

IDProjectCategoryView StatusLast Update
0000873OpenMPT[All Projects] User Interfacepublic2017-08-10 10:05
ReporterVinCMGAssigned Tomanx 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Platformx86 / x64OSWineOS Version(version plz)
Product VersionOpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first) 
Target VersionOpenMPT 1.27.01.00 (upcoming stable)Fixed in VersionOpenMPT 1.27.01.00 (upcoming stable) 
Summary0000873: Strange behavior with automatic text wrapping in Song Message window (Wine 1.6.2)
Description

Under certain circumstances, when typing a message that extends past the edge of the box, the last word on that line will appear and disappear at the beginning of the new line, causing the text on the new line to shift back and forth and overlap itself. The bug behaves differently depending on the words typed onto the new line.

Steps To Reproduce

In the attached mod, type a space followed by any text directly after the period at the end of the message. Typing " the quick brown fox" illustrates the bug especially clearly.

Additional Information

The bug does not occur with the above phrase if there is no space and/or period.

Fine:
"[...] gone now.the quick brown fox"
"[...] gone now the quick brown fox"
"[...] gone nowthe quick brown fox"

Buggy:
"[...] gone now. the quick brown fox"

TagsNo tags attached.
Has the bug occurred in previous versions?Yes, at least as far as 1.26.04.00
Tested code revision (in case you know it)

Activities

VinCMG

VinCMG

2016-09-07 07:52

reporter  

text box weirdness.zip (28,921 bytes)
Saga Musix

Saga Musix

2016-09-07 09:25

administrator   ~0002646

Looks like a bug in Wine's text control, since OpenMPT doesn't really do anything special, apart from setting a custom fixed-width font (which is not found or applied on your setup)...

manx

manx

2016-10-02 08:01

administrator   ~0002682

Technical stuff:
OpenMPT is (/was) in fact doing a couple of suboptimal or plain weird things here (like enforcing a custom character width even for fixed-width fonts or modifying the text edit control text in a way that apparently is not guaranteed to work (and Wine failed here)).

manx

manx

2016-10-02 08:04

administrator   ~0002683

Should be fixed in r7216 now.
We do not use a wrapping text control any more but instead a non-wrapping one with horizontal scrollbar.
Additionally, OpenMPT will now (for IT modules) use the same editor width that Impulse Tracker uses (75 chars), and use the full available width for other formats (MPTM, XM).

Issue History

Date Modified Username Field Change
2016-09-07 07:52 VinCMG New Issue
2016-09-07 07:52 VinCMG File Added: text box weirdness.zip
2016-09-07 09:25 Saga Musix Note Added: 0002646
2016-09-07 09:33 manx Status new => confirmed
2016-09-08 06:55 manx Assigned To => manx
2016-09-08 06:55 manx Status confirmed => assigned
2016-09-08 06:55 manx Target Version => OpenMPT 1.27.01.00 (upcoming stable)
2016-10-02 08:01 manx Note Added: 0002682
2016-10-02 08:04 manx Status assigned => resolved
2016-10-02 08:04 manx Resolution open => fixed
2016-10-02 08:04 manx Fixed in Version => OpenMPT 1.27.01.00 (upcoming stable)
2016-10-02 08:04 manx Note Added: 0002683
2017-08-10 08:54 manx Relationship added related to 0001003
2017-08-10 10:05 manx Relationship deleted related to 0001003