View Issue Details

IDProjectCategoryView StatusLast Update
0000872OpenMPT[All Projects] Generalpublic2016-10-22 15:24
ReporterDrekinnAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first) 
Target VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)Fixed in VersionOpenMPT 1.26.06.00 / libopenmpt 0.2-beta20.2 (upgrade first) 
Summary0000872: Preview note via key hold in tree view causes instrument selection jump
Description

If you select an instrument in the tree view list and press and hold a note key to preview the instrument sound, the selection will rapidly cycle through the list, selecting other list items that begin with the letter of the note key being held. This makes wanting to listen to a list of looping instruments most irksome as you have to relocate the next instrument in the list each time. Could this please be fixed?

Steps To Reproduce

The reproducibility of this issue seems to differ depending on what is listed in the tree view, though I've noticed that first selecting an instrument in the 'GM.DLS / Drum Kits / 0: Standard' folder will always trigger it.

Tagsinstrument preview, tree view
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-09-06 12:06

administrator   ~0002643

I've struggled with fixing this for a while, but I just got a new idea. Please download r7062 or newer from https://buildbot.openmpt.org/builds/ (as soon as it's available there) to check if the tree view works as intended now.

Drekinn

Drekinn

2016-09-07 02:59

reporter   ~0002644

Saga,
I see the code file '/trunk/OpenMPT/mptrack/View_tre.cpp' listed there, but am not sure how to test it. Please advise.

Saga Musix

Saga Musix

2016-09-07 09:23

administrator   ~0002645

Click the second link, not the first.

Drekinn

Drekinn

2016-09-08 00:45

reporter   ~0002647

Ok, figured it out.

I tested the latest build (openmpt-win32old-1.27.00.08-r7066) and it has fixed the problem! Thank you! :)

Should I continue using this possibly unstable build or just wait until the next stable release? Happy to wait.

Saga Musix

Saga Musix

2016-09-08 10:40

administrator   ~0002648

I don't think there are currently any known problems with test builds, so you can continue using it (and report any issues that might be coming up).

Issue History

Date Modified Username Field Change
2016-09-06 07:10 Drekinn New Issue
2016-09-06 07:10 Drekinn Tag Attached: instrument preview
2016-09-06 07:10 Drekinn Tag Attached: tree view
2016-09-06 12:06 Saga Musix Assigned To => Saga Musix
2016-09-06 12:06 Saga Musix Status new => assigned
2016-09-06 12:06 Saga Musix Status assigned => feedback
2016-09-06 12:06 Saga Musix Note Added: 0002643
2016-09-07 02:59 Drekinn Note Added: 0002644
2016-09-07 02:59 Drekinn Status feedback => assigned
2016-09-07 09:23 Saga Musix Note Added: 0002645
2016-09-07 09:23 Saga Musix Status assigned => feedback
2016-09-08 00:45 Drekinn Note Added: 0002647
2016-09-08 00:45 Drekinn Status feedback => assigned
2016-09-08 10:40 Saga Musix Note Added: 0002648
2016-09-08 10:40 Saga Musix Status assigned => resolved
2016-09-08 10:40 Saga Musix Resolution open => fixed
2016-09-08 10:40 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-09-08 10:40 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-10-22 15:24 Saga Musix Fixed in Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.06.00 / libopenmpt 0.2-beta20.2 (upgrade first)