View Issue Details

IDProjectCategoryView StatusLast Update
0000867OpenMPT[All Projects] File Format Supportpublic2016-08-27 00:09
ReporterncovertAssigned ToSaga Musix 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first) 
Target VersionOpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first)Fixed in VersionOpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first) 
Summary0000867: Pattern restarts sometimes don't work in MOD's
Description

I don't know if this is a limitation of the MOD format or not, but sometimes, the restart position will lose its value after saving and reloading the MOD. I think it depends on how many patterns there are: that is, if there are at least a certain number of patterns, the restart position will retain its value. Othwerwise, it will reset to 0 the next time you load the module. So, is this merely a MOD limitation, or is it something that can be fixed?

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-08-25 22:01

administrator   ~0002627

The restart position must ignored in some cases, but that's usually only if it's higher than the last order position. In other words, without an example module you are encountering the issue with, I cannot comment on why it's happening.

Saga Musix

Saga Musix

2016-08-25 23:07

administrator   ~0002628

Okay, I found what might be the problem you are experiencing: Setting the restart order to be the last or second-to-last order will not load it correctly (but it's stored correctly in the file). If this is not what your are experiencing, then please upload an example file.

Saga Musix

Saga Musix

2016-08-25 23:22

administrator   ~0002629

Please try r6977 from buildbot as soon as it's up (https://buildbot.openmpt.org/builds/).

ncovert

ncovert

2016-08-26 22:40

reporter   ~0002631

The problem you described regarding the last or second-to-last was what I was experiencing. It seems to be resolved with r6986.

Issue History

Date Modified Username Field Change
2016-08-25 17:27 ncovert New Issue
2016-08-25 22:01 Saga Musix Note Added: 0002627
2016-08-25 23:06 Saga Musix Assigned To => Saga Musix
2016-08-25 23:06 Saga Musix Status new => assigned
2016-08-25 23:07 Saga Musix Note Added: 0002628
2016-08-25 23:22 Saga Musix Status assigned => feedback
2016-08-25 23:22 Saga Musix Note Added: 0002629
2016-08-26 22:40 ncovert Note Added: 0002631
2016-08-26 22:40 ncovert Status feedback => assigned
2016-08-27 00:09 Saga Musix Status assigned => resolved
2016-08-27 00:09 Saga Musix Resolution open => fixed
2016-08-27 00:09 Saga Musix Fixed in Version => OpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first)
2016-08-27 00:09 Saga Musix Target Version => OpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first)