View Issue Details

IDProjectCategoryView StatusLast Update
0000866OpenMPT[All Projects] Feature Requestpublic2016-08-26 18:24
ReporterEmeliaKAssigned ToSaga Musix 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first) 
Target VersionOpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first)Fixed in VersionOpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first) 
Summary0000866: Notification of invalid values for e.g. Vxx in IT format in status bar
Description

IT Vxx supports a range of 00-80, whereas OpenMPT allows the input of values from 00-FF. Since commands such as Pxy notify that erroneous values are undefined in the status bar, I believe Vxx and any command sharing its range behaviour would benefit from some similar notification.

Steps To Reproduce

1) In an IT format module, enter the Vxx command and fill in any value >80 (e.g. VFF). No indication of its erroneousness will be present, and the module will play regardless.

Additional Information

I do not know if any/which other commands may exhibit this behaviour.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-08-23 12:42

administrator   ~0002625

Fixed for global and channel volume in r6968.

Issue History

Date Modified Username Field Change
2016-08-22 15:54 EmeliaK New Issue
2016-08-22 17:33 Saga Musix Assigned To => Saga Musix
2016-08-22 17:33 Saga Musix Status new => assigned
2016-08-22 17:33 Saga Musix Product Version => OpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first)
2016-08-22 17:33 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-08-23 12:42 Saga Musix Status assigned => resolved
2016-08-23 12:42 Saga Musix Resolution open => fixed
2016-08-23 12:42 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-08-23 12:42 Saga Musix Note Added: 0002625
2016-08-26 18:24 Saga Musix Fixed in Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first)
2016-08-26 18:24 Saga Musix Target Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.05.00 / libopenmpt 0.2-beta20.1 (upgrade first)