View Issue Details

IDProjectCategoryView StatusLast Update
0000862OpenMPT[All Projects] Feature Requestpublic2016-10-13 23:12
ReportermanxAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.27.00.* (old testing) 
Target VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)Fixed in VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) 
Summary0000862: Always enable DMO emulation
Description

Use internal emulation of common DMO effects as fallback when system-wide DMOs are not installed.
This is useful on Wine 64bit because Winetricks currently cannot install 64bit DMOs. It's also useful on Wine in general as it allows using DMO effects without requiring the user to install them using Wineticks first (i.e. better out-of-the box experience).
It might also be useful on Windows Server if DMOs are not installed there by default (I did not check that).

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-10-13 22:55

administrator   ~0002695

r7256

Saga Musix

Saga Musix

2016-10-13 23:12

administrator   ~0002696

Internal emulation is used whenever no DMO plugins are found; I3DL2Reverb, Chorus and Flanger are not emulated yet.

Issue History

Date Modified Username Field Change
2016-08-13 12:25 manx New Issue
2016-10-13 22:55 Saga Musix Assigned To => Saga Musix
2016-10-13 22:55 Saga Musix Status new => resolved
2016-10-13 22:55 Saga Musix Resolution open => fixed
2016-10-13 22:55 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2016-10-13 22:55 Saga Musix Note Added: 0002695
2016-10-13 23:12 Saga Musix Note Added: 0002696