View Issue Details

IDProjectCategoryView StatusLast Update
0000841OpenMPT[All Projects] User Interfacepublic2016-08-02 22:08
ReporterRaptureAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.26.03.* (old testing) 
Target VersionOpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first)Fixed in VersionOpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first) 
Summary0000841: Pattern Editor Instrument button selectors assigned wrong
Description

When you click up and down on the up/down buttons left to the instrument selection dropbox (above the pattern order list), clicking up decreases an instrument by one (instead of increasing it) and vice versa. Confusing, since all other up/down buttons in OpenMPT work like they should.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-07-31 17:28

administrator   ~0002536

I think the rationale for the inverted behaviour might be that the spin buttons are placed right next to a dropdown list of possible instruments, and they reflect the order of items in that list. The default "previous / next instrument" shortcuts work the same way. I agree it's inconsistent in some way, though.

Rapture

Rapture

2016-07-31 17:57

reporter   ~0002537

I see... personally I would like to have it coherent too, so when I click on "up", I'm used to an increment of that figure or element. Would be nice to see it in one of the next updates in some time, although it's not really mandatory since it's just a small cosmetic touch, and I use the dropdown list directly either way or chose the instrument in the instrument tab.

Saga Musix

Saga Musix

2016-08-02 22:08

administrator   ~0002538

Changed in r6730.

Issue History

Date Modified Username Field Change
2016-07-31 14:01 Rapture New Issue
2016-07-31 14:02 Rapture Description Updated View Revisions
2016-07-31 14:02 Rapture Product Version => OpenMPT 1.26.03.* (old testing)
2016-07-31 17:28 Saga Musix Note Added: 0002536
2016-07-31 17:57 Rapture Note Added: 0002537
2016-08-02 22:08 Saga Musix Assigned To => Saga Musix
2016-08-02 22:08 Saga Musix Status new => assigned
2016-08-02 22:08 Saga Musix Status assigned => resolved
2016-08-02 22:08 Saga Musix Resolution open => fixed
2016-08-02 22:08 Saga Musix Fixed in Version => OpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first)
2016-08-02 22:08 Saga Musix Target Version => OpenMPT 1.26.04.00 / libopenmpt 0.2-beta20 (upgrade first)
2016-08-02 22:08 Saga Musix Note Added: 0002538