View Issue Details

IDProjectCategoryView StatusLast Update
0000798OpenMPT[All Projects] File Format Supportpublic2016-05-19 21:20
ReporterRevenantAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.26.00.* (old testing) 
Target VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)Fixed in VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first) 
Summary0000798: SoundFX sample length limit
Description

First of all, good work on the upcoming release (and thanks for merging my SoundFX loader!)

I found one last little issue with it after doing some heavier testing with r6354. At some point, I had noticed that the "dummy" 16-bit field in the sample field usually represented the sample size in words (without alignment), but in several modules didn't seem to be consistent with that, so I didn't use it.

Either way, the maximum sample size should probably be considered to be 128kb instead of 64kb. Currently the modules "stratosphere" and "stratosphere 2" by Kerni won't load because they both have at least one sample that is larger than 64kb.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-05-19 21:20

administrator   ~0002404

Fixed in r6387.

Issue History

Date Modified Username Field Change
2016-05-19 21:12 Revenant New Issue
2016-05-19 21:20 Saga Musix Note Added: 0002404
2016-05-19 21:20 Saga Musix Assigned To => Saga Musix
2016-05-19 21:20 Saga Musix Status new => resolved
2016-05-19 21:20 Saga Musix Resolution open => fixed
2016-05-19 21:20 Saga Musix Fixed in Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)
2016-05-19 21:20 Saga Musix Target Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)