View Issue Details

IDProjectCategoryView StatusLast Update
0000796OpenMPT[All Projects] Playback Compatibilitypublic2016-05-20 20:39
ReporterWoddAssigned ToSaga Musix 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.00.* (old testing) 
Target VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)Fixed in VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first) 
Summary0000796: Crash With Plugins
Description

I tried to play some modules with plugins, but they crash the application or, if debugging from the code, trigger a breakpoint.

Steps To Reproduce

Download a game such as Bookworm or Zuma and load its music. Attempting to play the module should trigon the crash or breakpoint.

Additional Information

The games can be obtained through http://store.steampowered.com/.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)6373

Activities

Saga Musix

Saga Musix

2016-05-18 13:15

administrator   ~0002390

Yeah right, I am not going to buy a game to test a crash. I have the original bookworm MO3 from Skaven's website and it doesn't crash. What exactly makes you think that it's related to plugins, anyway? And why don't you simply provide the crash dump generated by OpenMPT which would spare me from buying a game?

Wodd

Wodd

2016-05-18 13:57

reporter  

2016-05-18 08.53.44.zip (21,066 bytes)
Wodd

Wodd

2016-05-18 14:05

reporter   ~0002395

The reason that I assumed that it is related to plugins is because none of the modules that I have with Bookworm's music played, save one. But that module does not contain Bookworm's Echo plugin. By the way the none does include the original MO3 from the game's installation directory. I didn't know that you already had the music. Likewise with Zuma. It contains a plug in called Chorus. OpenMPT crashes while trying to play it also.

Saga Musix

Saga Musix

2016-05-18 14:10

administrator   ~0002397

I cannot debug a crash dump generated from self-compiled executables, so please always use the test builds from buildbot.openmpt.org when reporting issues.
Anyway, as suspected the plugins have nothing to do with this, but it looks like you are using the DirectSound driver for playback - is that the case? If so, please use something that is more suitable for your operating system, e.g. WASAPI.

Wodd

Wodd

2016-05-18 14:56

reporter  

OpenMPT Crash.PNG (10,049 bytes)
OpenMPT Crash.PNG (10,049 bytes)
Wodd

Wodd

2016-05-18 14:59

reporter   ~0002398

Last edited: 2016-05-18 15:00

View 2 revisions

Upon switching to the WASAPI sound device, I didn't see the error in the picture attached. But, I still heard the Windows Critical Stop sound and OpenMPT became unresponsive.

Saga Musix

Saga Musix

2016-05-18 15:01

administrator   ~0002399

Last edited: 2016-05-18 15:02

View 2 revisions

Please reproduce the bug with the official test builds from https://buildbot.openmpt.org/ then and attach the generated crash files. As said, I cannot debug memory dumps from executables compiled by yourself.

Wodd

Wodd

2016-05-18 15:14

reporter   ~0002400

Last edited: 2016-05-18 15:15

View 2 revisions

Upon running revision 6374 from that page and using the WASAPI sound device, Bookworm's music plays with no problems. I wonder what would cause the problem then.

Saga Musix

Saga Musix

2016-05-20 20:39

administrator   ~0002406

Should be fixed in r6391 (as per https://forum.openmpt.org/index.php?topic=5651.0)

Issue History

Date Modified Username Field Change
2016-05-18 13:08 Wodd New Issue
2016-05-18 13:15 Saga Musix Note Added: 0002390
2016-05-18 13:57 Wodd File Added: 2016-05-18 08.53.44.zip
2016-05-18 14:05 Wodd Note Added: 0002395
2016-05-18 14:10 Saga Musix Note Added: 0002397
2016-05-18 14:56 Wodd File Added: OpenMPT Crash.PNG
2016-05-18 14:59 Wodd Note Added: 0002398
2016-05-18 15:00 Wodd Note Edited: 0002398 View Revisions
2016-05-18 15:01 Saga Musix Note Added: 0002399
2016-05-18 15:02 Saga Musix Note Edited: 0002399 View Revisions
2016-05-18 15:14 Wodd Note Added: 0002400
2016-05-18 15:15 Wodd Note Edited: 0002400 View Revisions
2016-05-18 15:18 Saga Musix Status new => closed
2016-05-18 15:18 Saga Musix Resolution open => no change required
2016-05-20 20:39 Saga Musix Note Added: 0002406
2016-05-20 20:39 Saga Musix Status closed => resolved
2016-05-20 20:39 Saga Musix Resolution no change required => fixed
2016-05-20 20:39 Saga Musix Fixed in Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)
2016-05-20 20:39 Saga Musix Target Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)