View Issue Details

IDProjectCategoryView StatusLast Update
0000791OpenMPT[All Projects] Playback Compatibilitypublic2016-05-14 00:27
ReporterjanglerAssigned ToSaga Musix 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.25.04.00 / libopenmpt 0.2-beta16 (upgrade first) 
Target VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)Fixed in VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first) 
Summary0000791: Incompatible playback of out-of-range note delays
Description

This is from the old schismtracker.org "player abuse tests" suite. OpenMPT 1.18.02.00 was listed as handling this correctly, but the current stable version does not.

OpenMPT incorrectly handles row 013. I'm not exactly sure what it does, but it isn't correct. The row should have no effect other than to change the instrument.

Of course, out-of-range note delays might as well have undefined behavior, since they're nonsensical in the first place, so this is a pathological case.

Steps To Reproduce

Play the attached IT module in Impulse Tracker (v2.14), then in OpenMPT.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

jangler

jangler

2016-05-13 23:42

reporter  

out-of-range-note-delays.zip (3,754 bytes)
Saga Musix

Saga Musix

2016-05-13 23:47

administrator   ~0002370

Seems to be broken since OpenMPT 1.23, oops.

Saga Musix

Saga Musix

2016-05-14 00:27

administrator   ~0002373

Fixed in r6362.

Issue History

Date Modified Username Field Change
2016-05-13 23:42 jangler New Issue
2016-05-13 23:42 jangler File Added: out-of-range-note-delays.zip
2016-05-13 23:46 Saga Musix Assigned To => Saga Musix
2016-05-13 23:46 Saga Musix Status new => assigned
2016-05-13 23:47 Saga Musix Note Added: 0002370
2016-05-14 00:27 Saga Musix Note Added: 0002373
2016-05-14 00:27 Saga Musix Status assigned => resolved
2016-05-14 00:27 Saga Musix Resolution open => fixed
2016-05-14 00:27 Saga Musix Fixed in Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)
2016-05-14 00:27 Saga Musix Target Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)