View Issue Details

IDProjectCategoryView StatusLast Update
0000754OpenMPT[All Projects] Feature Requestpublic2016-04-26 15:53
ReporterncovertAssigned ToSaga Musix 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.26.00.* (old testing) 
Target VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)Fixed in VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first) 
Summary0000754: Add separate controls for old Protracker compatibility modes
Description

Currently there are only two checkboxes regarding MOD playback: Protracker 1/2 Mode and Amiga Frequency Limits.
The Protracker 1/2 mode disables panning commands, enables Amiga frequency limits, changes the way samples loop, and allows samples to be changed without a note next to it. However, I have come across some MOD's that use both the Amiga features and later features (such as both on-the-fly sample changing and panning commands.) I think that these playback options should be given separate checkboxes to allow said MOD's to be played back more accurately.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-03-04 21:19

administrator   ~0002272

Since you mention that you are using the current testing version, you already have extended compatibility settings - check out the "Edit Compatbility Settings" button.

Saga Musix

Saga Musix

2016-04-26 15:53

administrator   ~0002352

r6297 now adds an extra flag for sample swapping as well.

Issue History

Date Modified Username Field Change
2016-03-04 21:17 ncovert New Issue
2016-03-04 21:19 Saga Musix Note Added: 0002272
2016-04-26 15:53 Saga Musix Assigned To => Saga Musix
2016-04-26 15:53 Saga Musix Status new => assigned
2016-04-26 15:53 Saga Musix Note Added: 0002352
2016-04-26 15:53 Saga Musix Status assigned => resolved
2016-04-26 15:53 Saga Musix Resolution open => fixed
2016-04-26 15:53 Saga Musix Fixed in Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)
2016-04-26 15:53 Saga Musix Target Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)