View Issue Details

IDProjectCategoryView StatusLast Update
0000750OpenMPT[All Projects] Plugins / VSTpublic2016-02-17 08:28
ReporterHevipeikkoAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.25.04.00 / libopenmpt 0.2-beta16 (upgrade first) 
Target VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)Fixed in VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first) 
Summary0000750: Superior Drummer set loading issue after update
Description

Superior drummer wont load any selected drum sets anymore (after update from 1.24.x).
Even with older version Superior drummer didn't load sets automatically when selected (unlike DAW's) and for some reason required some (midi?) activity to trigger actual load of drum set.
But with current version even this trick is not working anymore.(just shows 0 MB loaded samples in Superior).

Steps To Reproduce

Load superior drummer to plugins and try to use as instrument.

TagsNo tags attached.
Has the bug occurred in previous versions?partially
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-02-16 08:39

administrator   ~0002257

I have an idea why that might happen, can you go to Help -> Show Settings Folder, open the plugin.cache file and paste the line that contains the Superior Drummer plugin here?

Hevipeikko

Hevipeikko

2016-02-16 14:59

reporter   ~0002259

Ha!.. after restart I managed to get it loading drum set (like before, loads set when start playback).
So yeah I'm ok if it works this way, but though would be nice if loads those sets while in VST GUI settings :)
Anyway, current cache for Superior ...

5673745064666832CD3B8282=C:\Program Files\VstPlugins\Toontrack\Superior Drummer.dll
5673745064666832CD3B8282.Flags=8709
Superior Drummer=5673745064666832CD3B8282

Saga Musix

Saga Musix

2016-02-16 15:08

administrator   ~0002260

Last edited: 2016-02-16 17:32

View 2 revisions

If my intuition is right, Superior Drummer has the same issue as EZDrummer, so I applied for this plugin's UID now (I cannot apply this fix automatically for all plugins, as it will break some other plugins).
r5937 should hopefully fix the issue - please download it from https://buildbot.openmpt.org/builds/ (32-bit version will be up in 15 minutes, 64-bit version in 1 hour) and check if it works any better for you.

Hevipeikko

Hevipeikko

2016-02-17 05:01

reporter   ~0002262

Yes, now loads nicely when selecting drum set

Issue History

Date Modified Username Field Change
2016-02-16 07:15 Hevipeikko New Issue
2016-02-16 08:39 Saga Musix Note Added: 0002257
2016-02-16 14:59 Hevipeikko Note Added: 0002259
2016-02-16 15:08 Saga Musix Note Added: 0002260
2016-02-16 15:08 Saga Musix Assigned To => Saga Musix
2016-02-16 15:08 Saga Musix Status new => assigned
2016-02-16 15:09 Saga Musix Status assigned => feedback
2016-02-16 17:32 Saga Musix Note Edited: 0002260 View Revisions
2016-02-17 05:01 Hevipeikko Note Added: 0002262
2016-02-17 05:01 Hevipeikko Status feedback => assigned
2016-02-17 08:28 Saga Musix Status assigned => resolved
2016-02-17 08:28 Saga Musix Resolution open => fixed
2016-02-17 08:28 Saga Musix Fixed in Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)
2016-02-17 08:28 Saga Musix Target Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)
2016-11-20 17:48 Saga Musix Category VST => Plugins (VST)
2016-11-20 17:48 Saga Musix Category Plugins (VST) => Plugins / VST