View Issue Details

IDProjectCategoryView StatusLast Update
0000746OpenMPT[All Projects] Generalpublic2016-02-04 22:26
ReporterSaga MusixAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.25.04.00 / libopenmpt 0.2-beta16 (upgrade first) 
Target VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)Fixed in VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first) 
Summary0000746: Note Cuts result in excessively large MIDI exports
Description

Due to the VST backend of the MIDI export, a Note Cut (^^^) results in tons of note-off events being written which can cause timing problems with some MIDI players and also bloats the size of the resulting file. Should probably be fixed by using IMixPlugin directly rather than CVstPlugin.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-02-04 22:26

administrator   ~0002244

Fixed in r5904.

Issue History

Date Modified Username Field Change
2016-01-27 21:23 Saga Musix New Issue
2016-01-27 21:23 Saga Musix Status new => assigned
2016-01-27 21:23 Saga Musix Assigned To => Saga Musix
2016-02-04 22:26 Saga Musix Note Added: 0002244
2016-02-04 22:26 Saga Musix Status assigned => resolved
2016-02-04 22:26 Saga Musix Resolution open => fixed
2016-02-04 22:26 Saga Musix Fixed in Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)