View Issue Details

IDProjectCategoryView StatusLast Update
0000731OpenMPT[All Projects] Generalpublic2015-12-15 13:44
ReporterRyan AlbanoAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.25.04.00 / libopenmpt 0.2-beta16 (upgrade first) 
Target VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)Fixed in VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first) 
Summary0000731: Extra-fine portamento control broken on custom tunings
Description

Extra-fine porta (like 'EE1') doesn't work in custom tunings.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2015-12-07 15:39

administrator   ~0002205

Last edited: 2015-12-07 15:41

View 2 revisions

Extra-fine slides seem to be indeed not implemented at all for custom tunings. <s>Since the smallest editable unit in custom tunings is one finetune step (the step of a fine slide), I guess it would make sense to apply the same scale as with the default tuning, i.e. extra-fine slides should be four times finer than one tuning finetune step.</s>
Fine portamento seems to be behave different from regular fine portamento already, so maybe extra-fine portamento should behave like normal file portamento and change the pitch by x finetune steps?

Ryan Albano

Ryan Albano

2015-12-08 05:43

reporter   ~0002211

Better yet, I would just make fine/extra fine porta three separate effects. Then you'd have full range control of each.

Saga Musix

Saga Musix

2015-12-08 12:12

administrator   ~0002213

Not really feasible in the current format. Besides, it was not question on how to organize things but rather how they should behave.

Ryan Albano

Ryan Albano

2015-12-09 00:21

reporter   ~0002215

Wait--forget my last note. You should just add a 'speed multiplier' with floating point precision at least! Then you could specify pitch changes by EXACT numerical amounts. It would be much simpler, not arbitrary, and a total blessing for just intonation composers like me. (I'm pretty sure there are others using this program for JI also. Would highly recommend it!)

Saga Musix

Saga Musix

2015-12-13 23:58

administrator   ~0002223

r5836 adds extra-fine slides in the spirit of "normal" fine slides: EEx/FEx slide by x finetune steps on the first tick of the row. There's still the possibility to slightly adjust this until the next official release.
You can grab the new version in a short while over here: https://buildbot.openmpt.org/builds/

I'm not really sure what a "speed multiplier" should do and what this implies for Just Intonation. Why would Just Intonation require any special handling that is currently not present?

Ryan Albano

Ryan Albano

2015-12-14 07:51

reporter   ~0002224

As I'll explain, just intonation in MPT still has a major problem.

Custom tunings are great--they're what have kept me embracing this program, since pretty much everyone else failed (or still fail) to see the value of tuning control via ratios.
So I created my JI scale in MPT, and everything worked fine--for a while.
The problem is, just intonation is not a limited scale but an INFINITE SERIES. There's no way to add notes to the custom tuning later on (without shifting the song completely off), nor is there any way for me to know what tones I'm actually going to use, a.k.a. predict the future!
The only way to shift the notes then was to use portamento, which is inexact (I did it by ear), and also differs depending on file type, player settings, the tuning's fine-tune steps, and probably more! I can't believe I spent the time I did justly-tuning that way! Looking back now, it looks verrry sketchy.
I guess what I'm asking for doesn't really fit the nature of MPT. I'm just saying--a simple playback speed multiplier would have been way better than the workaround I used. Currently, the musical lines I'd written are not documented (I can't confirm their 'relevance' in the song) aside from the 16 notes I happened to have added to the custom tuning, and are subject to be off-pitch anyway.
So regarding just intonation, I say the custom tunings aren't enough. I learned the hard way--portamento's not going to do it!

Saga Musix

Saga Musix

2015-12-15 00:19

administrator   ~0002225

Ok, that's pretty much off-topic regarding the original issue, but... wouldn't a pitch multiplier be equal to just changing the middle-C frequency of your samples?

Ryan Albano

Ryan Albano

2015-12-15 04:52

reporter   ~0002226

Yes. And I actually started using identical samples that only differ by sample rate because the 'portamento method' I described was a lost cause. I end up duplicating instruments just for rational pitch changes, but that's way inefficient, both in terms of time and filesize. A real-time sample-rate multiplier (and not an arbitrary one like portamento) would have been far better.

Anyway--I agree--we're getting pretty off topic!xD I might just do a separate feature request for a 'real-time numerically based sample rate multiplier'.

Saga Musix

Saga Musix

2015-12-15 13:44

administrator   ~0002227

Yes, please do. I'll consider the original issue resolved (unless something doesn't work as intended, of course)

Issue History

Date Modified Username Field Change
2015-12-06 23:53 Ryan Albano New Issue
2015-12-07 15:39 Saga Musix Note Added: 0002205
2015-12-07 15:39 Saga Musix Assigned To => Saga Musix
2015-12-07 15:39 Saga Musix Status new => assigned
2015-12-07 15:41 Saga Musix Note Edited: 0002205 View Revisions
2015-12-08 05:43 Ryan Albano Note Added: 0002211
2015-12-08 12:12 Saga Musix Note Added: 0002213
2015-12-09 00:21 Ryan Albano Note Added: 0002215
2015-12-13 23:58 Saga Musix Note Added: 0002223
2015-12-13 23:58 Saga Musix Status assigned => feedback
2015-12-14 07:51 Ryan Albano Note Added: 0002224
2015-12-14 07:51 Ryan Albano Status feedback => assigned
2015-12-15 00:19 Saga Musix Note Added: 0002225
2015-12-15 04:52 Ryan Albano Note Added: 0002226
2015-12-15 13:44 Saga Musix Note Added: 0002227
2015-12-15 13:44 Saga Musix Status assigned => resolved
2015-12-15 13:44 Saga Musix Resolution open => fixed
2015-12-15 13:44 Saga Musix Product Version => OpenMPT 1.25.04.00 / libopenmpt 0.2-beta16 (upgrade first)
2015-12-15 13:44 Saga Musix Fixed in Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)
2015-12-15 13:44 Saga Musix Target Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)