View Issue Details

IDProjectCategoryView StatusLast Update
0000640OpenMPT[All Projects] File Format Supportpublic2017-08-01 15:09
ReporterAmaroq_DricaldariAssigned ToSaga Musix 
PrioritylowSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindowsOS Version7
Product VersionOpenMPT 1.24.01.00 / libopenmpt 0.2-beta8 (upgrade first) 
Target VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)Fixed in VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) 
Summary0000640: Add legacy Amiga filename detection
Description

On some versions of the Amiga, file extensions are put before the filename instead of after it, much unlike modern operating systems. This makes it a tedious process trying to open modules that were made on older Amiga systems, since you need to enable all files to find them. Also, you can't do a regular file association thing with Windows, since it would detect the filename itself as the file extension due to the differences in syntax.

However, if somebody on the team could implement a quick workaround so that OpenMPT can natively detect Amiga-style extensions, then it might make things just slightly less tedious.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2015-01-12 21:30

administrator   ~0001935

Where exactly are you missing this functionality? The file browser already shows MOD.* files, but for e.g. non-native Amiga file types this doesn't make any sense of course.

Saga Musix

Saga Musix

2017-07-30 20:15

administrator   ~0003123

r8673 shows Amiga-style extensions in the tree view for modules. The other "open file" dialogs already did this for MOD files, as mentioned before.

Issue History

Date Modified Username Field Change
2015-01-12 21:27 Amaroq_Dricaldari New Issue
2015-01-12 21:30 Saga Musix Note Added: 0001935
2017-07-30 20:15 Saga Musix Status new => resolved
2017-07-30 20:15 Saga Musix Resolution open => fixed
2017-07-30 20:15 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-07-30 20:15 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-07-30 20:15 Saga Musix Note Added: 0003123
2017-08-01 15:09 Saga Musix Assigned To => Saga Musix