View Issue Details

IDProjectCategoryView StatusLast Update
0001166OpenMPT[All Projects] Feature Requestpublic2018-11-26 18:17
ReportersincxAssigned ToSaga Musix 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.28.00.* (current testing) 
Target VersionOpenMPT 1.28.01.00 (goals)Fixed in VersionOpenMPT 1.28.01.00 (goals) 
Summary0001166: Save Copy As option
Description

I've often found myself wanting to save copies of modules on the spot, for backup purposes or otherwise, so this would be a minor convenience, essentially a reverse Save As--a copy gets saved but the working version remains active instead of the new file becoming the working version (like notepad++'s save copy as feature if familiar). Would just save the slight annoyance of having to re-open the old copy, or copy the file externally.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2018-11-25 18:31

administrator   ~0003745

Implemented in r11001, soon available from https://builds.openmpt.org/builds/

Please give it a whirl before the OpenMPT 1.28 release to verify that it works as intended. ;)

sincx

sincx

2018-11-26 14:36

reporter   ~0003746

Seems to work perfectly! Thanks :)

Issue History

Date Modified Username Field Change
2018-11-20 17:24 sincx New Issue
2018-11-20 20:13 Saga Musix Assigned To => Saga Musix
2018-11-20 20:13 Saga Musix Status new => assigned
2018-11-25 18:31 Saga Musix Status assigned => feedback
2018-11-25 18:31 Saga Musix Note Added: 0003745
2018-11-25 18:32 Saga Musix Target Version => OpenMPT 1.28.01.00 (goals)
2018-11-26 14:36 sincx Note Added: 0003746
2018-11-26 14:36 sincx Status feedback => assigned
2018-11-26 18:17 Saga Musix Status assigned => resolved
2018-11-26 18:17 Saga Musix Resolution open => fixed
2018-11-26 18:17 Saga Musix Fixed in Version => OpenMPT 1.28.01.00 (goals)