View Issue Details

IDProjectCategoryView StatusLast Update
0001165OpenMPT[All Projects] Plugins / VSTpublic2018-12-21 19:11
ReporterREDrangeDalAssigned ToSaga Musix 
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS Version7
Product VersionOpenMPT 1.28.00.* (old testing) 
Target VersionOpenMPT 1.28.01.00 / libopenmpt 0.4.0 (upgrade first)Fixed in VersionOpenMPT 1.28.01.00 / libopenmpt 0.4.0 (upgrade first) 
Summary0001165: VSTi instruments still playing even when the keyboard keys are released
Description

I tried some VSTi instruments like Synth1, Nabla and StringSynth and all of them are keeping the instrument to continue to play in background even when I am no longer holding the keyboard keys that plays the instruments. I don't know why this is happening but in stable releases this bug isn't present.

Steps To Reproduce

Load a VSTi instrument, for example Synth1 and in Instruments tab press a key that plays the VSTi instrument, for example the "A" key and then release the keyboard key.

This bug is noticeable with a instrument like a pad, but the instrument is still playing even when the sustain parameter is set to 0 and then put back to 64 or any value, and the instrument is still playing, without pressing a key that plays the VSTi instrument.

Additional Information

I tried all the soundcard devices that are for Communication Headphones, such as WaveRT, DirectX and others and I still get the same result.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)1.28.00.40

Activities

REDrangeDal

REDrangeDal

2018-11-16 12:40

reporter   ~0003718

I have tested today more builds and I found that this bug is present from the version build of OpenMPT 1.28.00.36-r10954.

I hope this helps.

Saga Musix

Saga Musix

2018-11-16 14:12

administrator   ~0003719

Yeah I'm aware which change introduced it... I'm just not sure yet how to fix it.

Saga Musix

Saga Musix

2018-12-21 15:34

administrator   ~0003761

This should hopefully be fixed as of r11040. Please verify by downloading an updated test build from https://builds.openmpt.org/builds/ - it should be available in a few hours at the latest.

REDrangeDal

REDrangeDal

2018-12-21 19:09

reporter   ~0003762

I tested the latest build of the version of OpenMPT 1.28 and the bug is fixed. I also tested with other VSTi instrument plugins to be sure that the problem is fixed.

Issue History

Date Modified Username Field Change
2018-11-15 16:18 REDrangeDal New Issue
2018-11-15 19:53 Saga Musix Assigned To => Saga Musix
2018-11-15 19:53 Saga Musix Status new => assigned
2018-11-15 20:38 Saga Musix Priority low => high
2018-11-15 20:38 Saga Musix Severity minor => block
2018-11-16 12:40 REDrangeDal Note Added: 0003718
2018-11-16 14:12 Saga Musix Note Added: 0003719
2018-12-21 15:34 Saga Musix Status assigned => feedback
2018-12-21 15:34 Saga Musix Note Added: 0003761
2018-12-21 15:34 Saga Musix Target Version => OpenMPT 1.28.01.00 / libopenmpt 0.4.0 (upgrade first)
2018-12-21 19:09 REDrangeDal Note Added: 0003762
2018-12-21 19:09 REDrangeDal Status feedback => assigned
2018-12-21 19:11 Saga Musix Status assigned => resolved
2018-12-21 19:11 Saga Musix Resolution open => fixed
2018-12-21 19:11 Saga Musix Fixed in Version => OpenMPT 1.28.01.00 / libopenmpt 0.4.0 (upgrade first)