View Issue Details

IDProjectCategoryView StatusLast Update
0001141OpenMPT[All Projects] Audio I/Opublic2018-09-06 18:14
ReporterTotalcancerAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionno change required 
PlatformAMD Athlon 2gh sse asioOSWindowsOS VersionXp Sp3
Product VersionOpenMPT 1.27.06.00 / libopenmpt 0.3.7 (upgrade first) 
Target VersionFixed in Version 
Summary0001141: native command ":" bug
Description

ModPlug Tracker MPT
|...........
|A-311...:71
|...........
|...........
|A-311...SD7
|^^^........
|...........
|...........

Those two notes should sound same with setted up
8 ticks per row instead of that firse note linger and in general command ":" wont works with last tick.

TagsNo tags attached.
Has the bug occurred in previous versions?unknown
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2018-09-06 17:52

administrator   ~0003609

Last edited: 2018-09-06 18:14

View 2 revisions

SD7 is the last tick of a row with 8 ticks (SD0 is the first). It should be obvious that the two examples cannot possibly sound the same, because the note-off is on the next row in your second example. The :xy command cannot trigger a note-off on the next row.

Issue History

Date Modified Username Field Change
2018-09-06 17:51 Totalcancer New Issue
2018-09-06 17:52 Saga Musix Note Added: 0003609
2018-09-06 17:52 Saga Musix Status new => closed
2018-09-06 17:52 Saga Musix Resolution open => no change required
2018-09-06 18:14 Saga Musix Note Edited: 0003609 View Revisions