View Issue Details

IDProjectCategoryView StatusLast Update
0001136OpenMPT[All Projects] Plugins / VSTpublic2018-08-08 18:45
ReporterherodotasAssigned To 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionnot fixable 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.28.00.* (current testing) 
Target VersionFixed in Version 
Summary0001136: Buggy GUI of AaltoCM
Description

OpenMPT open AaltoCM (from Computer Music mag) plugin with buggy GUI. Some parameters and controlers are not possible to set properly. In other host, plugin works perfectly.

TagsNo tags attached.
Has the bug occurred in previous versions?I dont know.
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2018-08-07 20:20

administrator   ~0003586

I downloaded the non-CM version and it seems to work without issues. Are you running the plugin inside the plugin bridge?

herodotas

herodotas

2018-08-08 17:43

reporter  

rns.jpg (386,636 bytes)
herodotas

herodotas

2018-08-08 17:43

reporter   ~0003589

I use x64 version of Aalto in Openmpt x64 . You maybe can't see diference without comparing. Anyway, I share pictures of loaded Aalto in renoise and Openmpt. They look diferent and controllers works diferent (bad way in openmpt :|)

herodotas

herodotas

2018-08-08 17:43

reporter  

openmpt.jpg (428,000 bytes)
Saga Musix

Saga Musix

2018-08-08 17:44

administrator   ~0003590

It looks the same as in Renoise for me.

herodotas

herodotas

2018-08-08 18:10

reporter   ~0003591

Its default patch in both loaded, do you see diference, real??? Look carefully.

herodotas

herodotas

2018-08-08 18:12

reporter   ~0003592

dont see*

Saga Musix

Saga Musix

2018-08-08 18:15

administrator   ~0003593

Yes, I see all the colors and connections that are missing in your OpenMPT instance:



aalto.jpg (85,491 bytes)
aalto.jpg (85,491 bytes)
herodotas

herodotas

2018-08-08 18:19

reporter   ~0003594

I think is a bug

Saga Musix

Saga Musix

2018-08-08 18:24

administrator   ~0003596

Yes, and it's likely to be found in the plugin. Have you tried the non-CM version? The CM version is not available for download so I cannot try it, but maybe it misses a bugfix that can be found in the version that can be downloaded from their website.

herodotas

herodotas

2018-08-08 18:24

reporter   ~0003597

But full version loads normally like in your screenshot

herodotas

herodotas

2018-08-08 18:25

reporter   ~0003598

I can send CM version to you, its magware, so not big crime

Saga Musix

Saga Musix

2018-08-08 18:25

administrator   ~0003599

That's yet another indication that it's a plugin-specific bug that we can most likely not fix.

herodotas

herodotas

2018-08-08 18:28

reporter   ~0003600

Ok, thanks for attention, I can just sample it, anyway it is monophonic.

Issue History

Date Modified Username Field Change
2018-08-07 19:58 herodotas New Issue
2018-08-07 20:20 Saga Musix Note Added: 0003586
2018-08-08 17:43 herodotas File Added: rns.jpg
2018-08-08 17:43 herodotas Note Added: 0003589
2018-08-08 17:43 herodotas File Added: openmpt.jpg
2018-08-08 17:44 Saga Musix Note Added: 0003590
2018-08-08 18:10 herodotas Note Added: 0003591
2018-08-08 18:12 herodotas Note Added: 0003592
2018-08-08 18:15 Saga Musix File Added: aalto.jpg
2018-08-08 18:15 Saga Musix Note Added: 0003593
2018-08-08 18:16 Saga Musix Reproducibility always => unable to reproduce
2018-08-08 18:19 herodotas Note Added: 0003594
2018-08-08 18:24 Saga Musix Note Added: 0003596
2018-08-08 18:24 herodotas Note Added: 0003597
2018-08-08 18:25 herodotas Note Added: 0003598
2018-08-08 18:25 Saga Musix Note Added: 0003599
2018-08-08 18:28 herodotas Note Added: 0003600
2018-08-08 18:45 Saga Musix Status new => closed
2018-08-08 18:45 Saga Musix Resolution open => not fixable