View Issue Details

IDProjectCategoryView StatusLast Update
0001128OpenMPT[All Projects] File Format Supportpublic2018-06-12 16:35
ReporterSlenderAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.27.08.00 / libopenmpt 0.3.9/0.3.10 (upgrade first) 
Target VersionOpenMPT 1.27.09.00 / libopenmpt 0.3.11 (current stable)Fixed in VersionOpenMPT 1.27.09.00 / libopenmpt 0.3.11 (current stable) 
Summary0001128: DSMI AMF playback broken in libopenmpt in latest revision
Description

Example module: http://ftp.modland.com/pub/modules/Digital%20Sound%20And%20Music%20Interface/Yolk/coop-Legend/eye.amf
It seems that DSMI AMF playback in libopenmpt is broken in the latest revision. All DSMI AMFs I've played are silent when played in libopenmpt. OpenMPT is not affected.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)libopenmpt-0.4.0-pre.5+r10445

Activities

Saga Musix

Saga Musix

2018-06-12 13:18

administrator   ~0003550

Last edited: 2018-06-12 13:25

View 3 revisions

From what I can tell, this affects the latest OpenMPT development builds equally.
Correction: It happens in 32-bit builds but not in 64-bit builds.

By the way, you don't need to explicitly monitor all the issues you create, you will get notified of status updates regardless of that.

manx

manx

2018-06-12 13:28

administrator   ~0003552

I cannot reproduce any problem on Linux GCC 4.8. eye.amf plays fine for me with openmpt123 v0.4.0-pre.5, libopenmpt 0.4.0-pre.5+r10445.

Slender

Slender

2018-06-12 13:31

reporter   ~0003553

Only broken in 32 bit builds? That might explain why it played in OpenMPT, I chose the 64 bit download.

manx

manx

2018-06-12 13:33

administrator   ~0003554

I can reproduce on 64bit OpenMPT.

manx

manx

2018-06-12 13:45

administrator   ~0003555

OpenMPT r10445 32bit form buildbot (VS2015) is broken, 64bit plays something.
OpenMPT r10445 64bit VS2017 is also broken.

Saga Musix

Saga Musix

2018-06-12 14:15

administrator   ~0003556

Last edited: 2018-06-12 16:35

View 2 revisions

Fixed in r10447.
Fixed in r10448 (OpenMPT 1.27 / libopenmpt 0.3).
Fixed in r10449 (libopenmpt 0.2).

Issue History

Date Modified Username Field Change
2018-06-12 12:47 Slender New Issue
2018-06-12 12:51 Slender Summary DSMI AMF playback broken in latest revision => DSMI AMF playback broken in libopenmpt in latest revision
2018-06-12 13:18 Saga Musix Note Added: 0003550
2018-06-12 13:18 Saga Musix Assigned To => Saga Musix
2018-06-12 13:18 Saga Musix Status new => assigned
2018-06-12 13:25 Saga Musix Note Edited: 0003550 View Revisions
2018-06-12 13:25 Saga Musix Note Edited: 0003550 View Revisions
2018-06-12 13:28 manx Note Added: 0003552
2018-06-12 13:31 Slender Note Added: 0003553
2018-06-12 13:33 manx Note Added: 0003554
2018-06-12 13:45 manx Note Added: 0003555
2018-06-12 14:15 Saga Musix Note Added: 0003556
2018-06-12 14:16 Saga Musix Status assigned => resolved
2018-06-12 14:16 Saga Musix Resolution open => fixed
2018-06-12 14:16 Saga Musix Category libopenmpt => File Format Support
2018-06-12 14:16 Saga Musix Product Version => OpenMPT 1.27.08.00 / libopenmpt 0.3.9/0.3.10 (upgrade first)
2018-06-12 14:16 Saga Musix Fixed in Version => OpenMPT 1.27.09.00 / libopenmpt 0.3.11 (current stable)
2018-06-12 14:16 Saga Musix Target Version => OpenMPT 1.27.09.00 / libopenmpt 0.3.11 (current stable)
2018-06-12 16:35 manx Note Edited: 0003556 View Revisions