View Issue Details

IDProjectCategoryView StatusLast Update
0001110OpenMPT[All Projects] Audio I/Opublic2018-04-09 22:02
ReporterlegorythmeAssigned To 
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSGentooOS Version(version plz)
Product VersionOpenMPT 1.27.07.00 / libopenmpt 0.3.8 (current stable) 
Target VersionFixed in Version 
Summary0001110: Set High Offset not working with .xm
Description

Hello,

I just notcied that "Set High Offest" not working anymore with .xm files.

A lot of my songs ar impacted.

Tried previous version 1.26, same issue

Steps To Reproduce

. . . . . . . XA3 <= affected effect (XAx)
C-5 01 v64 9f2

TagsNo tags attached.
Has the bug occurred in previous versions?No, but I 'don't from which version it's not working anymore
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2018-04-09 21:43

administrator   ~0003494

Last edited: 2018-04-09 21:44

View 2 revisions

This is intentional. Command X extensions are a ModPlug extension (not supported by other XM-compatible players), hence they are only available for legacy XM modules created with OpenMPT versions where these extensions were still allowed.

If a file that is making use of command X extensions was previously working as intended (in a file made with ModPlug Tracker 1.16 or early OpenMPT versions), it may be a bug (but then you need to provide such a file to have a look at). If it just doesn't work in newly created files, everything works as intended. Please don't use this command in XM files. Use the IT or MPTM format if you need access to those commands.

legorythme

legorythme

2018-04-09 21:56

reporter   ~0003496

Ok, I understand. I should have migrated for a long time ago to other formats. I did not expected that.

I'm doing music since 1995 with it, approximately 300 to 400 songs to migrate...

Is there a way to convert or export to other format, like mptm? I couldn't find a way.

Saga Musix

Saga Musix

2018-04-09 22:02

administrator   ~0003497

Yes, you can change the format in the Song Properties dialog. Note that OpenMPT tries its best but such a conversion can often not be 100% accurate, so be sure to listen closely if anything sounds different afterwards. Often the changes are small and can be fixed with some manual work.

Note that, as said, old songs using this command should still play as intended, as long as they were saved with ModPlug Tracker. Sometimes we cannot 100% reliably detect if an XM file was saved with ModPlug Tracker, so if the commands stop working in some old MPT-made file, we might have to fix our tracker detection. But in that case I'd need the problematic files to have a look at.

Issue History

Date Modified Username Field Change
2018-04-09 21:37 legorythme New Issue
2018-04-09 21:43 Saga Musix Status new => feedback
2018-04-09 21:43 Saga Musix Note Added: 0003494
2018-04-09 21:44 Saga Musix Note Edited: 0003494 View Revisions
2018-04-09 21:56 legorythme Note Added: 0003496
2018-04-09 21:56 legorythme Status feedback => new
2018-04-09 22:02 Saga Musix Note Added: 0003497
2018-04-09 22:02 Saga Musix Severity crash => feature
2018-04-09 22:02 Saga Musix Status new => closed
2018-04-09 22:02 Saga Musix Resolution open => no change required