View Issue Details

IDProjectCategoryView StatusLast Update
0001091OpenMPT[All Projects] Generalpublic2018-02-24 20:08
ReporterwitoAssigned ToSaga Musix 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.27.05.00 / libopenmpt 0.3.6 (upgrade first) 
Target VersionOpenMPT 1.27.06.00 / libopenmpt 0.3.7 (upgrade first)Fixed in VersionOpenMPT 1.27.06.00 / libopenmpt 0.3.7 (upgrade first) 
Summary0001091: Crash on cleanup
Description

99% of the time I try to cleanup my patterns by using the built-in feature, it crashes. It even produced a crash file once.

Steps To Reproduce

Just use the cleanup feature in version 1.25.05.00

TagsNo tags attached.
Has the bug occurred in previous versions?No.
Tested code revision (in case you know it)

Activities

wito

wito

2018-02-23 20:02

reporter   ~0003439

I'll give you the crash info as soon as I can make it do so.

Saga Musix

Saga Musix

2018-02-23 20:03

administrator   ~0003440

Please provided the created memory dump, because otherwise I can just guess what's going wrong - cleanup doesn't cause any crashes here.

Saga Musix

Saga Musix

2018-02-23 20:22

administrator   ~0003441

Okay, I can reproduce a crash when using "delete all patterns", which was supposed to be fixed in 1.27.05.00 but apparently it's still there. Is this what you mean? All other functionality doesn't cause crashes for me.

wito

wito

2018-02-23 21:18

reporter   ~0003442

Yes, that is what I mean. It never crashed for me in the earlier versions. Should I still provide a memory dump?

Saga Musix

Saga Musix

2018-02-23 21:18

administrator   ~0003443

No need anymore, I already found the cause.

Saga Musix

Saga Musix

2018-02-23 21:29

administrator   ~0003444

Fix in r9761/r9762, which you can soon download from https://builds.openmpt.org/builds/

wito

wito

2018-02-23 22:50

reporter   ~0003445

Thanks Saga.

Issue History

Date Modified Username Field Change
2018-02-23 20:02 wito New Issue
2018-02-23 20:02 wito Note Added: 0003439
2018-02-23 20:03 Saga Musix Note Added: 0003440
2018-02-23 20:22 Saga Musix Note Added: 0003441
2018-02-23 21:18 wito Note Added: 0003442
2018-02-23 21:18 Saga Musix Note Added: 0003443
2018-02-23 21:29 Saga Musix Note Added: 0003444
2018-02-23 21:30 Saga Musix Status new => feedback
2018-02-23 21:30 Saga Musix Fixed in Version => OpenMPT 1.27.06.00 / libopenmpt 0.3.7 (upgrade first)
2018-02-23 21:30 Saga Musix Target Version => OpenMPT 1.27.06.00 / libopenmpt 0.3.7 (upgrade first)
2018-02-23 22:50 wito Note Added: 0003445
2018-02-23 22:50 wito Status feedback => new
2018-02-24 00:31 Saga Musix Status new => resolved
2018-02-24 00:31 Saga Musix Resolution open => fixed
2018-02-24 20:08 Saga Musix Assigned To => Saga Musix