View Issue Details

IDProjectCategoryView StatusLast Update
0001082OpenMPT[All Projects] Feature Requestpublic2018-02-11 16:07
ReporterharbingerAssigned ToSaga Musix 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) 
Target VersionOpenMPT 1.27.05.00 / libopenmpt 0.3.6 (current stable)Fixed in VersionOpenMPT 1.27.05.00 / libopenmpt 0.3.6 (current stable) 
Summary0001082: Find & Replace Pre-fill-in
Description

When only one event in the PE is selected, opening the Find & Replace dialog will populate the Find fields with the selection. The default location will be the given pattern in the given channel. This should reduce the number of clicks when the user knows what he wants to change, and it's only one tone in the pattern.

Additional Information

Changing one attribute in a Pattern within only one channel has many steps involved, but selecting the whole channel in the PE wont's help the Find dialog parse what should be changed. If the user knows what he wants to change, he can just select one example of it in the PE, then Find will assume that's what we're looking for. All the user has to do is define what he wants to replace it with.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2018-02-09 16:43

administrator   ~0003408

I have thought about this before - the reason it's not implemented yet is that it's definitely not always the workflow that the user may want. Quite often I find myself doing similar search(&replace) actions in a row, and in that case I'd have to re-enter my search terms every time.
I guess one way it could work that the behaviour you suggest is only applied when more than one column in a cell is selected, so that if there is no selection (the cursor just marks a single column), it would not change the default, but if the selection spans e.g. note + instrument, it would fill that in. I'm not really sure if that's any more sensible.

Saga Musix

Saga Musix

2018-02-09 19:57

administrator   ~0003411

Or another idea: We could populate those fields with pattern data where the checkbox has not been set in a previous search. Because then we can just repeat a previous search exactly the same way as before, or we can just quickly check the appropriate checkboxes for the other stuff.

Saga Musix

Saga Musix

2018-02-09 20:44

administrator   ~0003412

Okay, here's something to try... r9616 / OpenMPT 1.28.00.10 will be available soon at https://builds.openmpt.org/builds/ and automatically fills in those values that have not been used in a previous search. Let me know how that works for you. I also squashed four other bugs in Find&Replace while I was at it...

Saga Musix

Saga Musix

2018-02-11 16:06

administrator   ~0003414

This has been backported to OpenMPT 1.27.05.00, released today. Feel free to re-open if it doesn't feel quite right yet.

Issue History

Date Modified Username Field Change
2018-02-09 16:32 harbinger New Issue
2018-02-09 16:43 Saga Musix Note Added: 0003408
2018-02-09 19:57 Saga Musix Note Added: 0003411
2018-02-09 20:44 Saga Musix Assigned To => Saga Musix
2018-02-09 20:44 Saga Musix Status new => feedback
2018-02-09 20:44 Saga Musix Target Version => OpenMPT 1.28.01.00 (goals)
2018-02-09 20:44 Saga Musix Description Updated View Revisions
2018-02-09 20:44 Saga Musix Note Added: 0003412
2018-02-11 16:06 Saga Musix Note Added: 0003414
2018-02-11 16:07 Saga Musix Status feedback => resolved
2018-02-11 16:07 Saga Musix Resolution open => fixed
2018-02-11 16:07 Saga Musix Fixed in Version => OpenMPT 1.27.05.00 / libopenmpt 0.3.6 (current stable)
2018-02-11 16:07 Saga Musix Target Version OpenMPT 1.28.01.00 (goals) => OpenMPT 1.27.05.00 / libopenmpt 0.3.6 (current stable)