View Issue Details

IDProjectCategoryView StatusLast Update
0001072OpenMPT[All Projects] Generalpublic2017-12-12 20:52
ReporterjmkzAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (upgrade first) 
Target VersionOpenMPT 1.27.03.00 / libopenmpt 0.3.4 (current stable)Fixed in VersionOpenMPT 1.27.03.00 / libopenmpt 0.3.4 (current stable) 
Summary0001072: Autosave does not work
Description

When creating a song and using 'Keep Sample Data on Disk' for samples, does not trigger autosave (and even loading samples without keeping sample on disk). I set it every 1 minute and 40 backups per filename.

Steps To Reproduce

Create a new MPTM
Load sample by D&D into sample slots and tick 'Keep Sample Data on Disk'
Add some notes to pattern
Load other samples without 'Keep Sample Data on Disk'
Auto save still not working, notice that OpenMPT sets song as modified.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)r9355

Activities

Saga Musix

Saga Musix

2017-12-12 20:38

administrator   ~0003383

I'm not sure how you came to this very specific conclusion in the issue title, because Autosave currently just does not work at all at the moment (and it hasn't for about a month due to some refactoring). ;)

Saga Musix

Saga Musix

2017-12-12 20:50

administrator   ~0003384

Fixed in r9357.

Issue History

Date Modified Username Field Change
2017-12-12 18:11 jmkz New Issue
2017-12-12 20:21 Saga Musix Assigned To => Saga Musix
2017-12-12 20:21 Saga Musix Status new => assigned
2017-12-12 20:38 Saga Musix Note Added: 0003383
2017-12-12 20:44 Saga Musix Product Version OpenMPT 1.28.00.* (current testing) => OpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (upgrade first)
2017-12-12 20:44 Saga Musix Target Version => OpenMPT 1.27.03.00 / libopenmpt 0.3.4 (current stable)
2017-12-12 20:44 Saga Musix Summary Autosave does not work for MPTM using 'Keep Sample Data on Disk' => Autosave does not work
2017-12-12 20:50 Saga Musix Note Added: 0003384
2017-12-12 20:50 Saga Musix Status assigned => resolved
2017-12-12 20:50 Saga Musix Resolution open => fixed
2017-12-12 20:50 Saga Musix Fixed in Version => OpenMPT 1.27.03.00 / libopenmpt 0.3.4 (current stable)