View Issue Details

IDProjectCategoryView StatusLast Update
0001070OpenMPT[All Projects] Generalpublic2017-12-04 17:45
ReporterDrillimationAssigned To 
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionnot fixable 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (current stable) 
Target VersionFixed in Version 
Summary0001070: Unexpected closing of OpenMPT when loading an instrument
Description

When attempting to load an instrument via Windows Explorer, OpenMPT will simply close with no "stopped working" message.

Steps To Reproduce

Simply load an instrument

TagsNo tags attached.
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-12-03 12:47

administrator   ~0003371

Does it happen with any instrument? If it only happens with specific instrument files, please attach an example. Also, if available, please provide the crash dump from %TEMP%\OpenMPT Crash Files.

Saga Musix

Saga Musix

2017-12-03 12:50

administrator   ~0003372

Also, you have previously stated that you are using OpenMPT on an external hard drive. Please confirm if you are still doing that, and whether the drive is plugged in when the crash happens. We already explained to you that OpenMPT cannot work reliably when you unplug the drive it is running from (this is an operating system limitation, not a bug in OpenMPT).

Drillimation

Drillimation

2017-12-03 12:50

reporter   ~0003373

I now have OpenMPT installed on my main drive, and this can happen with any instrument.

Saga Musix

Saga Musix

2017-12-03 12:52

administrator   ~0003374

Last edited: 2017-12-03 12:52

View 2 revisions

What kind of formats does the crash happen with? Does it happen with both big and small files? Did it just start happening randomly?
We will need the crash dump that should be found in the location %TEMP%\OpenMPT Crash Files, as otherwise there is no way we can help you. Obviously OpenMPT doesn't crash with all instrument files for other persons.

Drillimation

Drillimation

2017-12-03 12:55

reporter   ~0003375

This can happen with any instrument, and OpenMPT doesn't generate a crash file upon this happening.

Saga Musix

Saga Musix

2017-12-03 12:57

administrator   ~0003376

Does this only happening when opening instrument files, or also when opening sample files? Does it happen when you drag-and-drop the instrument from Explorer into OpenMPT?

Drillimation

Drillimation

2017-12-03 12:58

reporter   ~0003377

This would happen when I click the Open icon on the instrument page and select and instrument there.

Saga Musix

Saga Musix

2017-12-03 13:04

administrator   ~0003378

If it doesn't happen when drag-and-dropping the files from Explorer, this confirms my suspicion that you have a buggy shell extension installed. Shell extensions modify the Open and Save As dialogs of any program, and many of them are buggy, causing the application to crash. I would advise you to review the installed applications on your system and check if any of them are shell extensions, or if they install one. A known buggy shell extension belongs to DaemonTools, but there are many others.
Another thing you can try is turning on or off the "Preview samples / instruments in file browser" option in the settings dialog (found in the "Samples" tab).

Issue History

Date Modified Username Field Change
2017-12-03 12:45 Drillimation New Issue
2017-12-03 12:47 Saga Musix Note Added: 0003371
2017-12-03 12:50 Saga Musix Note Added: 0003372
2017-12-03 12:50 Drillimation Note Added: 0003373
2017-12-03 12:52 Saga Musix Note Added: 0003374
2017-12-03 12:52 Saga Musix Note Edited: 0003374 View Revisions
2017-12-03 12:55 Drillimation Note Added: 0003375
2017-12-03 12:57 Saga Musix Note Added: 0003376
2017-12-03 12:58 Drillimation Note Added: 0003377
2017-12-03 13:04 Saga Musix Note Added: 0003378
2017-12-04 17:45 Saga Musix Priority high => normal
2017-12-04 17:45 Saga Musix Status new => closed
2017-12-04 17:45 Saga Musix Resolution open => not fixable