View Issue Details

IDProjectCategoryView StatusLast Update
0001059OpenMPT[All Projects] File Format Supportpublic2017-11-10 18:06
ReporterPiotrAssigned To 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version10
Product Version 
Target VersionFixed in Version 
Summary0001059: Custom file format
Description

There should be a new file format, that can be customized. For example, consider the volume of notes. In mptm file format, it's always in a scale out of 64. However you may want greater precision so you customize the file format to use a scale out of 256; the information about the file format customization is in header. Or the opposite; you may want to directly use fades like 16-12-9-7-5-4-3-2-1 (requires proper settings to seamlessly play consecutive notes) without multiplying the numbers by 4. Also, the custom file format should provide lots of flexibility, like allowing long pattern length (I don't like the idea of splitting songs). Oh, guess what? This custom file format can also have potential to provide a feature mptm doesn't: different time resolutions on different channels!

So, this custom file format simply should bypass limitations:

  1. of always having volume out of 64; there may be an option to freely select a fractional value from scale out of 1, or an option of having volume scale out of different integers
  2. of having only 1024 pattern length; people like me don't like the idea of splitting songs
  3. of having equal time resolution on every channel
  4. of only having 120 different pitches (finetuning doesn't fix the range problem)¹
    and some more you can think of.

¹For unusual type of tunings, like Hz-based (16, 32, 48, etc. Hz) or period (inverse Hz) based (8000, 4000, 2666.7, etc. Hz), you may run out of range quicker than octave based ones, also tunings like these have no generator built in so they are hard to create

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0000865 new Revised MPTM format - idea pool 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-11-10 17:27 Piotr New Issue
2017-11-10 18:04 Saga Musix Relationship added duplicate of 0000865
2017-11-10 18:06 Saga Musix Status new => closed
2017-11-10 18:06 Saga Musix Resolution open => duplicate