View Issue Details

IDProjectCategoryView StatusLast Update
0001004OpenMPT[All Projects] Generalpublic2017-08-10 17:35
ReporterPiotrAssigned ToSaga Musix 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first) 
Target VersionOpenMPT 1.26.13.00 / libopenmpt 0.2-beta27 (upgrade first)Fixed in VersionOpenMPT 1.26.13.00 / libopenmpt 0.2-beta27 (upgrade first) 
Summary0001004: Crash when setting octave for instrument with General tuning
Description

Trying to change the octave of a general tuning in the pattern editor leads to a crash.

This bug completely blows OpenMPT out of usability. When OpenMPT crashes, current file is lost forever. This is the most important problem!!!!!! It also physically places tears on my eyes. Setting octave is pressing a number key.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)1.26.12.00

Activities

Saga Musix

Saga Musix

2017-08-10 14:11

administrator   ~0003140

OpenMPT should of course not crash. However, when it does, and it has control over the crash, it will create a backup of all open files and it will notify you of the location of those backup files (they are located in %TEMP%\OpenMPT Crash Files).

Furthermore, if you disabled Autosave, it's your own fault. OpenMPT by default automatically saves backups every ten minutes, and you can increase this to save even more often.

Last but not least, we would like to know more about the crash. When does it happen? Do you use any VST plugins (by far the most common culprit for crashes)? Is a memory dump (.dmp file) created in %TEMP%\OpenMPT Crash Files? Without this memory dump, it will be hard to analyze what happened. See also the FAQ on creating memory dumps.

Piotr

Piotr

2017-08-10 14:22

reporter   ~0003141

Meet a custom alternative tuning, "Period".
It's General, all pitches are 1 and all pitch numbers below 0 and above 31 are called ERR, and 0 to 31 are called by their numbers. It's supposed to mimic number of samples for 8000Hz with sample for each pitch. After I finished it, I tried it. I tried to press octave key (number) on this tuning. It crashed, I could not use it, I could only end Windows warning with closing the program. Because of crash, the biggest problem that will ever exist occured. That is, all 32 samples are deleted forever and tears are placed on my eyes.

Saga Musix

Saga Musix

2017-08-10 14:28

administrator   ~0003142

Thanks for the detailed description, I can reproduce the issue now.

By the way, you do not need to use a custom tuning for your purpose: Instead of creating a tuning where each sample has a ratio of 1, you can instead use the Note Map of your instrument and set the first column of all notes to C-5. Then all samples are played at middle-C.

Saga Musix

Saga Musix

2017-08-10 14:47

administrator   ~0003143

Last edited: 2017-08-10 14:48

View 2 revisions

Please do not change the priority of the bug, this is up to the developers to decide (and "immediate" is not the correct priority for a bug that can be easily worked around).

Since I was able to reproduce the crash I can also say that in this type of crash, your module is not lost. As said before, you will find a backup of the module in %TEMP%\OpenMPT Crash Files. You can copy&paste this path into Explorer to find the files, although OpenMPT should have opened an explorer window on its where you can find the file.

Saga Musix

Saga Musix

2017-08-10 16:24

administrator   ~0003145

Fixed in r8743.

Piotr

Piotr

2017-08-10 17:30

reporter   ~0003146

Sorry to say, but I DO need a custom tuning. Otherwise the names won't be correct (numbers 0-31, ERR for outside range)

Piotr

Piotr

2017-08-10 17:32

reporter   ~0003147

And I use Windows, not Linux. So give me .exe installer, not source code.

Saga Musix

Saga Musix

2017-08-10 17:35

administrator   ~0003148

I did not expect you to compile the sourcecode yourself, the code revision is only mentioned for our own housekeeping. The fixed build was simply not available at the time of writing. You can now download it from https://builds.openmpt.org/builds/auto/openmpt-win32/

The next stable version will most likely be released this weekend.

Issue History

Date Modified Username Field Change
2017-08-10 14:07 Piotr New Issue
2017-08-10 14:11 Saga Musix Note Added: 0003140
2017-08-10 14:15 Saga Musix Priority immediate => normal
2017-08-10 14:15 Saga Musix Severity crash => block
2017-08-10 14:15 Saga Musix Status new => feedback
2017-08-10 14:16 Saga Musix Severity block => crash
2017-08-10 14:22 Piotr Note Added: 0003141
2017-08-10 14:22 Piotr Status feedback => new
2017-08-10 14:24 Piotr Priority normal => immediate
2017-08-10 14:28 Saga Musix Note Added: 0003142
2017-08-10 14:28 Saga Musix Category Accessibility => General
2017-08-10 14:28 Saga Musix Summary OpenMPT places tears on my eyes when it crashes => Crash when setting octave for instrument with General tuning
2017-08-10 14:34 Piotr Description Updated View Revisions
2017-08-10 14:37 Saga Musix Priority immediate => normal
2017-08-10 14:45 Saga Musix Assigned To => Saga Musix
2017-08-10 14:45 Saga Musix Status new => assigned
2017-08-10 14:45 Saga Musix Description Updated View Revisions
2017-08-10 14:47 Saga Musix Note Added: 0003143
2017-08-10 14:48 Saga Musix Note Edited: 0003143 View Revisions
2017-08-10 15:08 Piotr Description Updated View Revisions
2017-08-10 16:24 Saga Musix Status assigned => resolved
2017-08-10 16:24 Saga Musix Resolution open => fixed
2017-08-10 16:24 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-08-10 16:24 Saga Musix Target Version => OpenMPT 1.27.01.00 (upcoming stable)
2017-08-10 16:24 Saga Musix Note Added: 0003145
2017-08-10 16:26 Saga Musix Fixed in Version OpenMPT 1.27.01.00 (upcoming stable) => OpenMPT 1.26.13.00 / libopenmpt 0.2-beta27 (upgrade first)
2017-08-10 16:26 Saga Musix Target Version OpenMPT 1.27.01.00 (upcoming stable) => OpenMPT 1.26.13.00 / libopenmpt 0.2-beta27 (upgrade first)
2017-08-10 17:30 Piotr Status resolved => feedback
2017-08-10 17:30 Piotr Resolution fixed => reopened
2017-08-10 17:30 Piotr Note Added: 0003146
2017-08-10 17:32 Piotr Note Added: 0003147
2017-08-10 17:32 Piotr Status feedback => assigned
2017-08-10 17:35 Saga Musix Note Added: 0003148
2017-08-10 17:35 Saga Musix Status assigned => resolved
2017-08-10 17:35 Saga Musix Resolution reopened => fixed